Sealyu  2010-11-19

系统 iphoneOS4.1, Cydia

最近更新Cydia的时候总是出错,在更新Commcenter补丁的时候说要先卸载bspatch,但是在安装bsdiff的时候,bsdiff里也包含bspatch,所以在队列安装的时候没法满足依赖关系,导致Cydia卡在那里。<br />

在用终端(Terminal)使用root账户进入iphone文件系统后,发现跟Ubuntu等类Debian系统差不多,同样安装软件可以适用dpkg和apt-get。<br />
所以参考Ubuntu下安装软件的解决方法,终于解决了这个困扰了几天的问题。<br />

解决方法如下:<br />
1. 打开终端(Terminal), loading完后,输入su,回车。<br />
2. 输入密码,默认为:alpine
3. 输入:dpkg -i –force-overwrite /var/cache/apt/archives/XXX 。(其中的XXX为提示说无法覆盖的那个bsdiff_4.3-1xxxxx.deb那个文件)回车<br />
4. 输入: apt-get upgrade, 回车。<br />
4. 重启iphone
5. 进入Cydia查看更新,搞定<br />

Leave a Reply

电子邮件地址不会被公开。 必填项已用*标注